X  
登录

还没有账号?立即注册

忘记密码?
登陆
X  
注册

已经有账号?马上登陆

获取验证码
重新获取(60s)
立即注册
统计
  • 建站日期:2021-03-10
  • 文章总数:169 篇
  • 评论总数:7 条
  • 分类总数:21 个
  • 最后更新:7月4日
文章 综合技术

易语言QQ BKN计算方法

趣6网
首页 综合技术 正文
广告
广告

易语言编程

.版本 2

.子程序 计算bkn, 文本型
.参数 Skey, 文本型
.局部变量 基值, 整数型
.局部变量 计数, 整数型
.局部变量 长度, 整数型
.局部变量 结果, 整数型

基值 = 5381
计数 = 0
长度 = 取文本长度 (Skey)
.判断循环首 (计数 < 长度)
    基值 = 基值 + 左移 (基值, 5) + 取代码 (Skey, 计数 + 1)
    计数 = 计数 + 1
.判断循环尾 ()
结果 = 位与 (基值, 2147483647)
返回 (到文本 (结果))

JS版版本

function getBKN(str){ 
   var hash = 5381; 
   for(var i = 0, len = str.length; i < len; ++i) 
   { 
   hash += (hash << 5) + str.charAt(i).charCodeAt(); 
   } 
   return hash & 0x7fffffff; 
}

版权说明
文章采用: 《署名-非商业性使用-相同方式共享 4.0 国际 (CC BY-NC-SA 4.0)》许可协议授权。
版权声明:未标注转载均为本站原创,转载时请以链接形式注明文章出处。如有侵权、不妥之处,请联系站长删除。敬请谅解!

-- 展开阅读全文 --
隐藏win10中(此电脑)里的6个子文件夹
« 上一篇
免费全民K歌、绿钻会员、腾讯视频
下一篇 »
为了防止灌水评论,登录后即可评论!
注册登录

已有 2 条评论

  1. 上看看 Lv.1

    说道:事故发生的,麻烦您第三方所得税的分类考试的

  2. 上看看 Lv.1

    说道:d.nfgjsdnfsm,XZMFDKS 真的没法是是

HI ! 请登录
注册会员,享受下载全站资源特权。
登陆 注册
社交账号登录

热门文章

标签